鳩の谷の街へ ようこそ

いろいろと気になったことをゆるく書きます。

Acer easyStore H342 に WHS2011 に無人インストールする。

Posted by Hatono-tani : 2011年4月17日


鳩の谷の街です。

タイトルの通りで easyStore H342 に WHS2011 を乗せてみたいと思います。

かつて”Vail”のBetaテストの初めの頃からできるだけ軽量なOSで運用したいという開発チームの思惑を常に持っていて、ATOMのデュアルコアのマシン(330ですが)を使用してのテストを初版のBeta版からずーっと対象にしていました。

と、いうわけでわりと勝手がしれているH342に対して無人インストールをどのようにしていくかを書いてみます。

基本的な流れは WHS2011 を1ドライブ構成でセットアップしたい時 と同じなのですが、違いについて書いておきます。今回はデフォルトに近い形で実装したいという観点から書きます。

今回は cfg.ini はこのように設定します。


[WinPE]
InstallSKU=SERVERHOMEPREMIUM
ConfigDisk=1
CheckReqs=0
WindowsPartitionSize=
61440
[InitialConfiguration]
AcceptEula=true
ServerName=(サーバー名)
PlainTextPassword=(管理者のパスワード)
PasswordHint=(パスワードのヒント)
Settings=All


相違について記述をすると….

①基本的にインストールする場合に、WHS2011の最低のメモリー要件を満たすために、本体に2GB以上のメモリー(DDR2-800)を実装する必要があります。(理想は4GBを実装して頂きたいのですが、1枚4GBのメモリーは割と高いのでちょっとそこはコストとの比較なので考えてみてください、ここに実装の時のメモを書いてあります。)

②HDDについてですが、基本的に未使用ディスクの状態にして、一番下のディスクに1台だけ置くようにしてください。もしどうしても未使用ディスクを使用せずにインストールをしたい場合は、サーバーリカバリの最初の手順にあるように起動時にリカバリースイッチ(左の穴のところ)を押す必要があります。

③WHS2011をインストールするときに必要なUSBメモリはフロントでもリアでも認識できるようですが、極力リアにで使ってください。

④無人インストールを実施する場合は特にキーボードやマウスを必要としませんが、必ず有線LANケーブルをつないでルーターからDHCPでIPを割り当てられるように必ず設定します。(この設定をしないとインストールの途中で失敗します(必修要件)

⑤作業にかかる時間は大体1時間弱なのですが、放置していても勝手にやってくれます。最初にサーバーを見つける方法はエクスプローラーからネットワークを参照すれば特定できると思います。

⑥H342にはもともとサーバーリカバリーのためのエリアがあります。そのためにWHS2011をインストールすると、WHSのサーバーリカバリの領域が見えます。この領域には一切操作をしないでください。(触ってしまうとWHSへ戻せなくなります。) 下記の画像の243MBというやつがそれに該当します。

00-Vail-Install-DRV101-drvinfo

運用上の注意事項

・HDDのLEDが使用できません。(ソフトウェアの制御のため)

・左側のLEDは表示されますが、明るさの制御ができません。(フルでひかります。)

今回の例はH342ということで書いていますが、おそらくH340でもできると思ってます。(実機が無くて確認できないので保障は出来ないんですが。。)

どなたでもできるというわけでもないのですが、参考になれば幸いです。

広告

コメント / トラックバック15件 to “Acer easyStore H342 に WHS2011 に無人インストールする。”

  1. koh_new said

    お世話になってます。現在WHS2011のRC版を運営しています。RC版からRTM版の修正内容があまりわからないんでなんともなのですが。

    現在のRC版はスマートフォンからAndroid端末ならばOpera Mobile または Opera Mini。 iphoneであればDownload Lite等でサーバーにある自炊したPDFをダウンして読めるようにしていますが、サーバーにつないだ一番始めのページがスマートフォン用になっています。これをデスクトップビューにするとPCでみる画面に変わりますが、また、スマホ用に戻すリンクがありません。これはRTM版にはリンクがついていますか?

    スマホでアクセスする場合、スマホ用のブラウザが自動でデスクトップビューを読み込むとその後のファイルダウンロードが正常にできなくなります。(ブラウザのダウンローダーとWHSのダウンローダーのスクリプトか何かが一致しないためだと思います。)

    ですが、スマホ用のページからアクセスするとスマホのブラウザのダウンローダー等で問題なくファイルのダウンロードが可能になります。

    ただこのスマホ用ページのリンクがないと、初めからスマホ用のページを読み込んでくれるブラウザをひたすらに探す必要が出てきますし、見つかってもブラウザアプリがなんからで使えなくなった場合、まったくWHSを利用できなくなる可能性があります。

    iphoneで現在問題発生して1つブラウザが不能になりました。

    またOpera Miniでもアップデートで等で問題発生して試行錯誤状態です。現在auのXOOMでいろいろ試みていますが、operaMiniしかもともと使えない状態です。

    スマホ用のWHS2011アプリが出てくれば問題ないかもしれませんが・・・。

    できれば、スマホページに飛ばす強制手段なんかをWHSでできるのならば何か設定を教えてください。

  2. Duane said

    記事については、ホームサーバ設定の参考にさせていただいています。

    さて、上記の記事を参考に、我が家のH342にUSBメモリからWHS2011 DSP版のインストールを試みているのですが、途中まで進んで(15分くらい?)停止してしまいます。状況は、
    ・赤iLED点灯(点滅しない)
    ・ディスクのLEDの2と3が赤点灯(点滅しない)

    上記の記事との違いは、ドライブ1に入れたディスクが2TBであることくらいです。
    また、WindowsPartitionSize=MAX でも試してみましたが、状況は変わりません。

    なお、数回試しましたが、その都度、サーバリカバリDISCと裏のボタンを使用して
    ディスクを初期化しています。(裏のボタンだけでは、進まないようでしたので)

    コンソールが接続できれば、何が起きているかわかるのですが、接続していないもので。
    お気づきの点があれば、アドバイスください。

    • お世話になります。
      > ・ディスクのLEDの2と3が赤点灯(点滅しない)
      この事象は”Bootするデバイスが無い”というエラーです。

      時間的に解釈すると、15分というのは正常に行っていた場合は最初の再起動がかかる時間にしては少し速いかなという感じです。
      なので、考えられそうな話しとしては
      ・USBからのBootがうまく行ってない。
      くらいしか思いつかないです。
      認識しているかどうかの判断は cfg.ini に書き換えが入っている場合は認識されていて、そうでない場合は認識されていないと思います。
      ちなみにサーバーリカバリーディスクで初期化していると記述されてますが、多分その方法では初期化されたDISKではないように思います。
      何回もUSBを使用するようでしたら”Processed=true”という一文が追加されるのでインストールの時に消してください。よろしくお願いします。

      • Duane said

        さっそくのコメント、どうもありがとうございます。

        確かに、cfg.iniは更新されていません(Processed=trueは追加されていません)ので、2回目のブートに失敗しているように思います。
        エラーになるタイミングは、何回か試しましたが10~15分の間でした。

        手持ちのUSBメモリで8GBより大きいのは、今使っている32GBのしか無いため、他のUSBメモリを調達して試してみます。
        また、ディスクのフォーマット方法については、途中別の新品ディスクで試してみた時も同じ現象でしたが、他のフォーマット方法を試してみたいと思います。

      • えーと、補足させてください。

        cfg.iniは更新されていません(Processed=trueは追加されていません)ということは、
        BootシーケンスでUSBを認識していないと思われます。つまり、最初からBoot出来ていないことになります。
        で、この原因なのですが、USBメモリの中でBootできるものとBootできないものがあります。
        自宅のものもできるものとできないものが半々づつあります。
        (ちなみに自分の環境ではSunDiskを使ってます。あとはTranscendあたりをつかってます
        単価が安いメーカだと割とダメな確率が高い気がします。)

        もし、可能であるならばcfg.iniがない状態で他のPCとかで開始画面まで表示されることを確認していただいて、
        最後に cfg.ini を追加した状態で作業していただくといいと思います。その方が事前に確認できると思います
        参考になれば幸いです。m(__)m

  3. disco said

    いつも参考にさせていただいております。本サイトを拝見することが無かったらWHSを投げ出している所でした。ありがとうございます。

    さて、本題にうつりますと、これから実用動作をチェックしなければなりませんが、「基本導入」は「H340」でも問題無く出来ました。という報告です。
    リモートデスクトップにてデバイスマネージャに!や×がありませんでしたのでまぁ問題無いかと思います。
    何かしら問題が生じましたら、再度ご報告にお邪魔させていただきたいと思います!

    では、失礼いたします。

  4. jcb01351 said

    お世話になります。

    小生もH340へWHS2011を導入したいと思っておりますが、ここで紹介されているWHS2011はDSP版でしょうか? それとも新規インストール版でしょうか?

    以上、宜しくお願いします。

  5. cydoc said

    はじめまして、WHSv1/WHS2011共に利用する上で大変参考にさせて頂いております。ありがとうございます。

    EX490にUSBメモリ無人インストールで無事WHS2011を入れることが出来、例のLEDライトドライバも入れて全く問題なく動作するようになりました。
    そこで質問なのですが、WHS2011の標準機能のバックアップからの、OSのリストアを無人で行うためのcfg.iniの作成はできないのでしょうか?
    リストアもWHS2011のインストールディスクから行うようなので、cfg.iniで選択肢を指定してやると(「既存のバックアップの中で最新のものから復元」以外を選択するのは困難と思いますが)、
    不可能ではないように思うのですが、作成方法が分かりません。
    もし方法がないのであれば、やはりディスプレイ出力するしかないように思います(そうでなければシステムディスクの別パーティションのデータを諦めてクリーンインストールするしかない)。
    方法がないのであれば標準機能のバックアップの魅力も低下するので、やはりVVAULTやDrivePoolなどDE代替Add-inの使用を考えてしまいます。

    宜しければ御意見頂けるとありがたいです。

  6. ぼち said

    いつもお世話になっております。

    私のH340は未使用HDDを一番下スロットに入れてのWHS2011セットアップが出来ないのです。一番上でセットアップできます。
    そして、電源投入時に裏面のリカバリスイッチを押さないとセットアップが走りません。
    機種やロットによって違うのか、私のやり方が特殊だったのか、何かおかしいのでしょうか?

    • お世話になります。最近あまり活動できてなくてすみません。
      あまり確信がないのですが、自分だったら基盤とHDDのケーブル回り、もしくは、SATAのコネクター周りを疑います。
      ちなみに元々の構成だったら、したから順番に認識していくはずなので最初がダメで2番目がOKだったらその可能性は
      高い気がします。
      参考になるといいのですが(-_-;)

コメントを残す

以下に詳細を記入するか、アイコンをクリックしてログインしてください。

WordPress.com ロゴ

WordPress.com アカウントを使ってコメントしています。 ログアウト / 変更 )

Twitter 画像

Twitter アカウントを使ってコメントしています。 ログアウト / 変更 )

Facebook の写真

Facebook アカウントを使ってコメントしています。 ログアウト / 変更 )

Google+ フォト

Google+ アカウントを使ってコメントしています。 ログアウト / 変更 )

%s と連携中

 
%d人のブロガーが「いいね」をつけました。